Network / DNS Latency Issues
Incident Report for Cycling '74
Resolved
According to our Cloud Provider the upstream networking issues have been resolved. If you continue to see outages and remain unable to access Cycling '74 resources and services please get in touch with our support.
Posted Sep 12, 2023 - 01:12 PDT
Investigating
Our Engineering time is aware of issues impacting upstream networking routes.

Users in some isolated regions may experience latency or remain unable to use Cycling '74 services and reach our Website and Authorization system.

Our engineers are in contact with our Cloud Provider and actively working with them to resolve the issue.
Posted Sep 11, 2023 - 09:47 PDT
This incident affected: cycling74.com, Cloud Compiler, Package Manager, and Authorization.